Skocz do zawartości

Forum XperiaSite.pl używa ciasteczek (cookies). Przeczytaj naszą Polityka prywatności i plików cookies by dowiedzieć się więcej. Kliknięcie w przycisk obok wyłączy to okno.    Zgadzam się na ciastka
  • Log In with Google      Logowanie »   
  • Rejestracja



Zdjęcie

Bluetooth OBD

bluetooth

  • Zaloguj się, aby dodać odpowiedź
4 odpowiedzi w tym temacie

#1 ONLINE Millerek

Millerek

    Zaczyna się uczyć

  • Reputacja: 0
  • 24 postów

Napisano 04 wrzesień 2019 - 16:20

Witam, dotychczas używałem Z5 Premium i zmieniłem ją na XZ Premium.
Na Z5 Premium używałem OBD V-link w samochodzie Mazda6.
Tego samego V-linka używałem w innych samochodach mając Z1 czy później Z5 Premium.
Wszystko było super, dopóki nie zmieniłem telefonu na XZ Premium.

Bluetooth XZ Premium nie łączy się (bądź są wielkie problemy) z V-linkiem, w każdym samochodzie, z żadnymi innymi interfejsami OBD bluetooth a mam ich kilka sztuk.

Mam 3 inne OBD bluetooth, na Z1, Z5 Premium, na różnej maści chińskich telefonach działają, a na XZP są problemy.

Dokładnie pisząc, XZP widzi, paruje wszystkie OBD.
Ale, jeśli w ogóle nawiąże połączenie bo to najczęstszy problem, to jeśli nawet połączy się z tymi OBD to odczyt parametrów czy modułów samochodu trwa nawet do 30 minut. Na innych urządzeniach z androidem trwa to raptem 5 sekund.
Na innych telefonach czy na innych OBD nie ma problemów z połączeniem, wszystko działa jak należy, zawsze byłem zadowolony, do czasu użytkowania XZP bo tulko z tum telefonem jest jakiś problem.

Programy to Forscan i Torque. Programy te widzą że niektóre OBD, w różnych momentach czasami i nie dość rzadko że OBD są różnej jakości, że są klonami elm 327, że czasami połączenie jest słabe, ale łączyły i nie było problemu.

Problem występuje na XZ Premium.
Nie wiem o co chodzi, może jakieś ustawienia, może to, że to pierwszy mój sony z android 9 Pie. Na innych 9.0 Pie wszystko działa (Xiaomi i Samsung).

Wszelka pomoc mile widziana.

Użytkownik Millerek edytował ten post 04 wrzesień 2019 - 16:32

  • 0

#2 OFFLINE Mojzesz

Mojzesz

    Sensei

  • Reputacja: 1211
  • 10232 postów
  • Skąd:Rawa Maz/Skierniewice
  • Telefon:Inny
  • Android:Nie podano
  • Rom:Oxygen OS Android 10
  • Kernel:Stock
  • Operator:Plus

Napisano 04 wrzesień 2019 - 16:36

1. Android Pie może mieć problemy po części z OBD ale nie powinien. Nowszy standard bluetooth to druga strona medalu.

2. Można zmienić oprogramowanie choćby na oficjalne Sony nie tracąc gwarancji (poradniki przypięte nad każdym działem).

3. Sprawdzałeś na urządzeniach z nowym standardem bluetooth, bądź też z nową wersją androida?

 

Strzelam, że masz Pie - to tylko mój domysł. Jednakże jeśli czyta ale bardzo powoli to wiadomo, że intefejsy nie chcą współgrać z tym telefonem. iCar 4 i taki zwykły gargamel niebieski ELM sprawdzałem i ujdzie (nie na Sony) ale też miałem trochę problemy przynajmniej z tym no-name.


  • 0

#3 ONLINE Millerek

Millerek

    Zaczyna się uczyć

  • Autor tematu
  • Reputacja: 0
  • 24 postów

Napisano 04 wrzesień 2019 - 16:42

XZ Premium jest z sieci Play, inne moje sony również są z Play.

XZP tylko ma problemy, Samsung i Huawei na 9.0 nie mają problemów.

Próbowałem naprawy oprogramowania z a pomocą Sony companion ale wyskakuje błąd.

Nigdy nie robiłem żadnych rootow czy preinstalacji poza Companion żadnego androida, nie znam się bo nie było mi to potrzebne.

Miało być lepiej a jest gorzej.

Owszem, czasami różnej maści OBD są problemowe więc posiadam OBD takie z którymi nie ma problemów, tzn jak widać są ale tylko na xz premium.

Użytkownik Millerek edytował ten post 04 wrzesień 2019 - 16:44

  • 0

#4 OFFLINE ch3mn3y

ch3mn3y

    (o_O) Jaola Tymon (O_o)

  • Reputacja: 2086
  • 20932 postów
  • Skąd:Województwa Nadmorskie
  • Telefon:Xperia Z1
  • Android:Pie (9.0)
  • Rom:CarbonRom (cr-7.0)
  • Kernel:RZKernel (3.0)
  • Operator:Rebtel

Napisano 05 wrzesień 2019 - 07:30

Uruchom Ustawienia, przejdź do O telefonie i 7 razy tapnij w "Numer kompilacji". Cofnij się, a dostaniesz opcję "Dla programistów" i tam poszukaj opcji związanych z Bluetooth. Pobaw się nimi i któraś powinna być OK.


  • 0

#5 ONLINE Millerek

Millerek

    Zaczyna się uczyć

  • Autor tematu
  • Reputacja: 0
  • 24 postów

Napisano 18 wrzesień 2019 - 22:26

Dzięki za odzew, ale ustawienia programisty są włączane i zabawa z ustawieniami nic nie wnosi, nic nie zmienia. Chyba że to jakieś zabawy w postaci Lotto i trzeba ustawić przykładowo 3 ustawienia razem w odpowiedni sposób.

Nic nie pomaga, żadne ustawienia nic nie zmieniają, żadnej poprawy nie ma.

Inne gorszej maści telefony jak Huawei, Samsung, Xiaomi, KrugerMatz i inne szorty nie mają żadnego problemu z każdym moim OBD, łącznie już 4 sztuki.

A myślałem że zmieniając stary na nowy (Z5P na XZP), będzie tylko lepiej, ale jak widać jest gorzej.
  • 0







Również z jednym lub większą ilością słów kluczowych: bluetooth

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych


XperiaSite.pl jest nieoficjalnym i niezależnym serwisem poświęconym smartfonom z serii Sony Xperia. Wszystkie znaki towarowe, nazwy firm oraz logotypy wymienione na stronie należą do ich właścicieli.Strona ma charakter informacyjny.