Skocz do zawartości

Forum XperiaSite.pl używa ciasteczek (cookies). Przeczytaj naszą Polityka prywatności i plików cookies by dowiedzieć się więcej. Kliknięcie w przycisk obok wyłączy to okno.    Zgadzam się na ciastka
  • Log In with Google      Logowanie »   
  • Rejestracja



Zdjęcie

Z5 Premium i problem z samochodowym bluetooth

Z5 Premium Bluetooth Passat B6

5 odpowiedzi w tym temacie

#1 OFFLINE Mayk3l

Mayk3l

    Coś tam skrobnął

  • Reputacja: 2
  • 10 postów
  • Skąd:Oświęcim
  • Telefon:Xperia Z5 Premium
  • Android:Nougat (7.1.2)
  • Rom:LineageOS 14.1
  • Operator:T-Mobile

Napisano 19 maj 2020 - 13:33

Witam,

Kiedy chcę sparować moją Xperię Z5 Premium z samochodem VW Passat B6 (wersja po małym lifcie - wnętrze jest z B7) to ten nie chce, bo twierdzi, że urządzenie jest niekompatybilne. Co ciekawe kiedyś parowałem go i działał bez problemu. Czy może to być spowodowane odblokowanym bootloaderem albo brakiem kluczy DRM? Kiedyś się zbytnio pospieszyłem i zapomniałem o zrobieniu kopii zapasowej, a gdy bez kluczy chcę zablokować bootloadera, to aplikacja aparatu się zacina.

Zakładam, że jedynie brak DRM i odblokowany bootloader jest problemem, bo moduł Bluetooth jest w zupełności sprawny, działa ze słuchawkami. Znalazłem tutaj taki sposób na te klucze

Treść ukryta. Proszę Zaloguj się lub Zarejestruj by zobaczyć zawartość.

Czy to mogłoby zadziałać? Nie będzie żadnych problemów?

Zauważyłem, że nie działa xReality (co jest zrozumiałe) ale jakość zdjęć się chyba nie pogorszyła, bynajmniej tego nie zauważyłem. Jak ktoś wie o co chodzi to może pomóc.

 

Bootloader jest odblokowany, bo kiedyś próbowałem LineageOS ale teraz jestem na bazowym Androidzie 7.1.1

I oczywiście - samochód ma sprawny Bluetooth - łączy się z Samsungiem Wave, Nokią 3220 jak i Samsungiem Galaxy S5, więc tutaj mamy wachlarz oprogramowań.


  • 0

#2 OFFLINE yurec1st

yurec1st

    Stały Bywalec

  • Reputacja: 2
  • 44 postów
  • Skąd:ŚLĄSK
  • Telefon:Xperia Z5 Compact
  • Android:Nougat (7.1.1)
  • Rom:32.4.A.1.54
  • Kernel:3.10.84-perf-g99119bc
  • Operator:Play

Napisano 19 maj 2020 - 13:40

Sparuj inny telefon z autem, dowiesz się po której stronie leży problem.


  • 0

#3 OFFLINE juggler

juggler

    Administrator

  • Reputacja: 693
  • 5638 postów
  • Skąd:Warszawa
  • Telefon:Xperia XZ Premium Dual
  • Android:Pie (9.0)
  • Rom:47.2.A.2.33
  • Kernel:stock
  • Operator:Play

Napisano 19 maj 2020 - 14:36

Zakładam, że jedynie brak DRM i odblokowany bootloader jest problemem, bo moduł Bluetooth jest w zupełności sprawny, działa ze słuchawkami. Znalazłem tutaj taki sposób na te klucze https://forum.xda-de...es-drm-t2930672Czy to mogłoby zadziałać? Nie będzie żadnych problemów?

Zdarzały się przypadki, że nawet wersja oprogramowania miała znaczenie, szkoda że nie przetestowałeś jak miałeś tego Lineage'a. Co do linku, mogłoby to zadziałać, ta metoda "oszukuje" system w ten sposób, by myślał że klucze są. A to wystarczy czasem, by funkcje wróciły (nie wszystkie). 

 

Sparuj inny telefon z autem, dowiesz się po której stronie leży problem.

Hej. Kolega napisał wyżej, że już próbował to robić.  


  • 1

#4 OFFLINE Mayk3l

Mayk3l

    Coś tam skrobnął

  • Autor tematu
  • Reputacja: 2
  • 10 postów
  • Skąd:Oświęcim
  • Telefon:Xperia Z5 Premium
  • Android:Nougat (7.1.2)
  • Rom:LineageOS 14.1
  • Operator:T-Mobile

Napisano 19 maj 2020 - 16:53

Okej, poeksperymentuję jeszcze z tym jak będzie na LineageOS.

Co do wersji oprogramowania to kiedyś udało mi się połączyć na tej samej, tylko właśnie przed tym jak zacząłem eksperymentować z ROMami.

Posprawdzam i powiem co udało mi się zrobić, jak tylko znajdę czas, na razie dzięki za odpowiedzi ;)


  • 1

#5 OFFLINE Mayk3l

Mayk3l

    Coś tam skrobnął

  • Autor tematu
  • Reputacja: 2
  • 10 postów
  • Skąd:Oświęcim
  • Telefon:Xperia Z5 Premium
  • Android:Nougat (7.1.2)
  • Rom:LineageOS 14.1
  • Operator:T-Mobile

Napisano 24 sierpień 2020 - 16:44

Witam serdecznie, po długiej przerwie. Zaprezentuję wnioski z eksperymentów:

Xperia Z5 Premium z ROMem LineageOS 14.1 nie chce współpracować z samochodem.

Z fabrycznym oprogramowaniem od Sony (Android 7.1.1) z zastosowaniem poradnika Juggler'a (wcześniej nie zrobiłem kopii kluczy drm) również nie działa.

Do tego zastanawiam się nad tym, czy aby na pewno kiedykolwiek parowałem Xperię z tym samochodem, bo chyba pomyliłem ją z innym telefonem.

Zagłębiłem się nieco w temat. Moduł BT znajdujący się w Passacie B6 2009 wymaga obsługi rSAP (Remote Sim Access Protocol). Polega to na tym, że telefon udostępnia samochodowi dane karty SIM, dzięki czemu samochód przejmuje nad nią kontrolę, korzysta z osobnej anteny GSM itd. Najprawdopodobniej moja Xperia takiej funkcji nie obsługuje, więc temat zamknięty.

Z tego co również znalazłem to można eksperymentować dalej i uruchomić tą funkcję, lecz na razie nie mam takiej potrzeby, ani zbytnio chęci.


  • 1

#6 OFFLINE Mojzesz

Mojzesz

    Sensei

  • Reputacja: 1308
  • 10573 postów
  • Skąd:Rawa Maz/Skierniewice
  • Telefon:Inny
  • Android:Nie podano
  • Rom:Android R beta 1
  • Kernel:Stock
  • Operator:Play

Napisano 25 sierpień 2020 - 04:05

Parrota sobie wsadź do autka i będzie hulać pewnie.
  • 0



Dodaj odpowiedź



  



Również z jednym lub większą ilością słów kluczowych: Z5 Premium, Bluetooth, Passat B6

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych


XperiaSite.pl jest nieoficjalnym i niezależnym serwisem poświęconym smartfonom z serii Sony Xperia. Wszystkie znaki towarowe, nazwy firm oraz logotypy wymienione na stronie należą do ich właścicieli.Strona ma charakter informacyjny.